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The Windows Inkscape interface looks different
from other software tools.  Here is a brief 
discussion of interface items:  

1 Menu: 10 top level menu items.

22

22 Tool Bar: Total 21 tools in version 0.92.2; we only 
 discuss a few of them.

3 Tool Setting: Change with tool selection.

4 Ruler: Drag from ruler to create guides. 

5 Page: Where drawings are shown. Only objects
or paths inside page will print.

6 Canvas: Put temporary objects outside page.

7 Setting Window: Float (pop-up) style is easy

to access (Ctrl + Shift + key).

8 Command Bar: Not very useful.

9 Snap Bar: Shift + % to turn on and off snapping.

10 Color Pallet: You can drag and drop color boxes.

11 Status Bar: Easy access to fill and stroke.

Inkscape Interface

Inkscape Default Settings

Inkscape has lots of settings that you can 
customize. However, a few default settings do 
not work very well in Windows, and it is 
suggested to change them. 

You can access Preferences dialog by menu 
Edit > Preferences (Ctrl + Shift + P). 

In the Preference window, make those changes:
Tools (select) > Bounding box to use

Geometric bounding box

Interface > Windows (select) > Dialog behavior

Floating
 (requires restart)

Interface > Windows (select) > Dialog Transparency
Opacity when unfocused: 1.0000

Inkscape Books

Inkscape Tutorial for Engineers

georgexyz.com

Page 1

Last Modification : 3/18/2019

Advantages of Inkscape:

Free and open source;1.
No installation is needed for portable version.

Basic tools are good and reliable;2.
Drawing, layer, align, and text tools are all good.

File format support is extensive;3.
Support PDF, PNG file import and export.
Open format SVG as default file format.

Dmitry Kirsanov

Tavmjong Bah

Book of Inkscape

1999 published
472 Pages

Inkscape Guide

2011 published
504 Pages
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Inkscape Navigation
We introduce basic Computer Graphic (CG) drawing 
concepts such as page size, unit, and dimension 
and discuss Inkscape navigation on this page.

Common US engineering drawing paper sizes:

Letter Size: 8.5" x 11"

Ledger/Tabloid Size: 17" x 11" 

Full Size/Arch D: 36" x 24"

Note the ledger size area is twice as large as letter size. 

Those navigation shortcuts should be memorized:

(+):

(-):

Middle Mouse Button (Scroll): 

Drag (click and hold to move) to pan the page

Single click to enlarge the page

Shift + click to reduce page size

(5):

Those 3 shortcuts are indispensible for daily work.

Full Size/Arch D, W: 36"

Fu
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4"W: 17" 

H
: 1

1"
 

Enlarge, actually it is key '=' on keyboard 

Zoom out, make objects smaller.

Number 5 is the shortcut for fitting the page

Coordination

x

y

Inkscape 
Coordination 

System

Units
Self-defined

x

y

Coordination
System in
Inkscape
SVG Files

Units
are in mm

Arrow keys are for moving selection by a nudge factor, 
which is 2 SVG pixels by default.

Shift + Arrow: Move selection by ten times of
the nudge factor

Alt + Arrow: Move selection by one screen pixel.

Mouse scroll is very important in Inkscape.

Other shortcuts to be aware of:

(1):

(2):

(3):

Zoom to 1:1

Zoom to 1: 2

Zoom to selection

Ctrl + Arrow: Scroll canvas.

(4): Zoom to drawing

(`): Previous zoom

Shift + (`): Next zoom

%
5

Menu: File > Document Properties (Ctrl + Shift + D)

Units

inch (in)

pixel (px) 1/96 inch, the width of above line is 1px, 
page border is 1.5px.  DPI is Dots Per Inch, 
which means number of pixels in an inch.

point (pt) 1/72 inch, typographic concept, MS Word
default font is 11 pt Calibri. 

mm, cm 1mm =  1/25.4 inch. 
1 millimeter = 1/10 centimeter.

We normally have unit inch for page size, pixel for line 
width, and point for text size in the US. 

1 inch

1 cm = 10 mm

<rect id="rect1407"
   style="opacity:1;...l" 
   width="16" height="10"
   x="105" y="160.9" />

Page size is 11 x 8.5 in, or 279.4 x 215.9 mm. 
SVG code shows x=105, y=160.9 (top left corner). 
Tool setting bar shows X: 105, Y:45 (bottom left ).  
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Inkscape Tools
Inkscape version 0.92.2 has 21 tools.  We discuss 
10 most useful tools for engineers.

Selector (S, F1, Spacebar)

Node (N, F2)

Zoom (Z)

Measurement (M)

Rectangle (R)

Ellipse/Arc (E)

Polygon/Star (*)

Bezier (B)

Type or Text (T)

Dropper (D)

The letters (lower case) in the parentheses 
are shortcuts. For example, press the lower-
case letter 'z' key to choose Zoom tool.

Selector (S, F1, Spacebar)

Single click: Select object or path; Resize object.
Second click: Rotate and skew selection.
Double click: Adjust other object properties.

This tool is very different from other drawing software.

Node (N, F2)

The Inkscape does not include some common CAD 
tools.  The Node tool and Guideline work together to 
achieve some CAD functions. 

A
BLine 1

The steps to trim line 1 in the above figure:

Select two lines, Ctrl + D to duplicate them.
Shift + G (or Object > Objects to Guides) to 
create two Guidelines.
Select Line 1; F2 Select Point A; Move A to B.
(Shift + % to turn on Snap); Delete Guidelines.

1.
2.

3.

When you move one end of a line, press two keys
Ctrl + Alt to preserve the line direction. 

Zoom (Z)
You can navigate via shortcuts on the previous page 
instead of Zoom tools. 

Measurement (M)
Because object and path dimensions are shown on 
the tool setting bar, the Measurement tool is not used 
very often.  

Rectangle (R)

Ctrl key: Draw a Square.
Shift key: Drawing starts from center.
Double click an rectangle to change corner radius.

The tool is also for squares and rectangles with radius.

Single click an icon chooses a tool.
Double click an icon brings up Preference 
setting window for the tool.

Ellipse/Arc (E)

Ctrl and Shift keys are the same as Rectangle tool.

This tool is used for both Ellipse (including circle) and 
Arc.  Sometimes, we use Bezier tool to draw curves 
instead of Arc tool.

Polygon/Star (*)

The Star tool is rarely used for engineering drawings.  
However, sometimes we need the Polygon tool.  

Bezier (B)
The Bezier tool is the backbone of the Inkscape soft-
ware. You draw both lines and curves with this tool. 

Type or Text (T)

The Text tool in Inkscape is good, but not perfect. 

Dropper (D)
The Dropper tool is very simple. If you want to fill the
color of an object on the page with another color, you
select the object, choose the tool, and click on another
object (even on an image).   Press Shift key to change
stroke color.

5

10

15

20

Single Click Second Click

Double Click

Guidelines
You can drag from ruler to create guides, or use menu 
Object > Objects to Guides (Shift + G) to create guides.
Double clicking a guide brings up a dialog, and you can 
delete the guide.  Access menu Extension > Render > 
Guides Creator to delete all guides.  
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SVG File Format

SVG Document
The format of an SVG file is,

<svg version="1.1"
         xmlns="http://www.w3.org/2000/svg" 
         ... >
   <line x1="40" y1="30" x2="240" y2="100" stroke="black" />

</svg>

You can add width, height, and viewBox attributes 
to the SVG tag.  The code below sets the document
unit to millimeter.

<svg ...width="11in" height="8.5in" viewBox="0 0 279.4 215.9">

Shape Elements
The six SVG shape elements are line, rect, circle, 
ellipse, polyline, and polygon.

rect: x y width height
circle: cx cy r
ellipse: cx cy rx ry
polyline and polygon: points

Paths
A path element has a d attribute which contains a 
sequence of drawing commands. Uppercase com-
mands indicate that parameters are absolute values, 
and lowercase are relative values.

M/m: move to
L/l: line to
H/h, V/v: horizontal (vertical) line to
Q/q, C/c: quadratic (cubic) curve to
T/t, S/s: smooth quadratic (cubic) curve to
A/a: elliptical arc to
Z/z: close the path

The default Inkscape file format is Scalable Vector 
Graphics (SVG).  The SVG specification is an open 
standard developed by the World Wide Web Con-
sortium (W3C).  

SVG files are XML text documents. All major
modern web browsers support SVG rendering.

    <rect id="rect5368"
       style="opacity:1; ... "
       width="15" height="10"
       x="20" y="141" />

(20,141)

    <path id="path5479"
       sodipodi:type="star"
       sodipodi:sides="5"
       ......
       d="m 36.115624,170.25937 ..." />

Star object does not have a corresponding shape 
element in SVG specification.  Inkscape saves paths 
with special attributes in an SVG file.

    <path id="path6993"
       style="fill:none;stroke:#000000; stroke-
                   width:0.264px; stroke-linecap:butt;
                   stroke-linejoin:miter;stroke-opacity:1"
       d="m 106.39,181.78 h 5.62 c 2.23,3.86 
              3.77,3.19 5.62,0 1.84,-3.19 3.46,-3.74 
              5.62,0 l 5.98,0"
       inkscape:connector-curvature="0" />

Defs, View, and Metadata
The Inkscape SVG has Defs, View, and Metadata 
elements at the top of svg document.  

Defs elements are for gradient, pattern, marker, 

namedview is for document specific options.
clipping path, mask, filter definitions.  

Metadata stores information about the document.

    <path id="path6130"
       style="fill:none;stroke:#000000; ...
                   marker-end:url(#marker6317)"
       d="m 107,61 h 13" />

  <defs id="defs858">   
   <marker id="marker6317"
       inkscape:isstock="true" style="overflow:visible;"
       refX="0.0" refY="0.0"
       orient="auto" inkscape:stockid="Arrow2Lend">
      <path id="path6315"
         transform="scale(0.8) rotate(180) translate(9.0,0)"
         style="fill-rule:evenodd;stroke:#000000; ..."
         d="M 0.0,0.0 L 0.0,-2.5 L -11.0,0.0 L 0.0,2.5 L 0.0,0.0 z " />
     </marker> ... </defs>

XML Editor

You can change the attribute value in the lower-right
textbox of XML editor (Ctrl + Shift + X), and press Ctrl + 
Enter to commit the change.  XML editor is one of the 
most powerful tools in Inkscape.

Texts
Texts in SVG 1.1 have two element tags <text> and 
<tspan>.

Element <text> requires two attributes, x and y.
Many properties are the same as in CSS.
Element <tspan> can change text styles.

BoldText Example

<text id="text4262" xml:space="preserve"
       style="font-style:normal;font-variant:..."
       x="189.79" y="145.95" >
    <tspan id="tspan4260" sodipodi:role="line" 
       x="189.79" y="145.95"
       style="font-style:normal;font-variant:..">
       <tspan id="tspan4266" style="font-weight:bold">Bold</tspan> 
       <tspan id="tspan4268" style="font-style:italic" >Text</tspan> 
        Example
   </tspan>
</text>

http://archive.petercollingridge.co.uk/svg-tutorial

SVG Study Materials
The web site by Peter Collingridge has good tutorial.

A book titled SVG Essentials is also good.
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Bézier Curves
Traditional engineering drawing CAD software does
not have Bézier tool, but the tool is the backbone of
drawing programs like Inkscape.

 Pen Tool - Mode

When you click the Pen (B) tool, the Tool Setting bar 
shows 5 modes you can choose. 

Equations

The curves are named after Pierre Bézier, who used
them to design automobile bodies at Renault and
published them in 1962.  

We have two points P0 (x0, y0) and P1 (x1, y1) in a
coordinate system, the line between two points is

Quadratic Bézier curve has three control points P0,
P1, and P2. The curve equation is

m 30,125 q 10,-10 20,0

Cubic Bézier curve has four control points P0, P1, 
P2, and P3.

m 30,185 c 5,-7.5 15,-7.5 20,0

Inkscape Pen tool only generates cubic curves.  
You have to edit SVG to get quadratic curves.

The first mode is regular Bézier line, and the fourth
and fifth modes are straight and paraxial lines.  

Create Dots
You need to choose the straight or paraxial line mode 
to create dots. 

Choose the Pen (B) tool; select fourth or fifth mode.

Ctrl + Click to place the dot.

Double click the Pen tool to choose dot diameter, 
and the unit is in (millimeter x stroke width). 

Bézier Curves
Here are the steps to create Bézier curves.

Click at 0; drag and release at 1

Click at 6; drag to 7. 

Click at 3; drag to 4. Point 2 shows up.

0

1

0

1

2

3

4

0

1

2

3

4 5

6

7

m 111,162 c 14,-12 19,-7 24,1

m 111,183 c 14,-12 19,-7 24,1 5,8 11,5 18,0

Pen Tool

Pen tool is very versatile.  

Node Types

There are four types of node: Corner (cusp), Smooth,

Press Enter key or double click to end a path.

Backspace key to delete a node.

Click mouse to create lines; Click and drag to create
Bézier curves.

If a path is selected, you can start drawing from end
nodes to continue the current path.

Corner Smooth  (Half-smooth)

Press and hold Shift key.

Auto

Corn
er

Sm
ooth

Sym
m

etri
c

Auto

Node Tools

0

1

2

3

4
Drag from 2 to 3.

Drag from 3 to 4, release mouse.

Symmetric, and Auto.

Here are the steps to create a corner node.

Join 2 nodes t
o 1

Join 2 nodes

Bre
ak 1 node to

 2

Bre
ak 2

 nodes

Inse
rt

Delete

M
ake

 lin
e

M
ake

 cu
rve

Release Shift key.

Symmetric
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Fill and Stroke
In Inkscape or other vector drawing programs, you 
style objects or paths with fill and stroke.  

Stroke Style

When you select an object, the dialog shows the 
style of the object. 

Join

Three join types: round, bevel, and miter. Miter-limit
value is for miter join type only.

If you want to set the default stroke style of a tool
such as Bezier tool, double click the tool icon on 
the toolbar. 

The stroke width is a unit.  When stroke width is 1px, 
the miter limit of 4 is 4px.  Customized dashes and 
markers are represented in unit of stroke width.  You 
need to set the stroke width to a large value such
as 10px to see the effects of Join, Cap, and Order.

Status Bar - Fill, Stroke, and Opacity

You can set the fill or stroke paint to flat (or solid), 
gradient, or patterns. 

You can change  fill/stroke, stroke width, and opacity 
on the status bar (right mouse click). 

Round Bevel Miter

d

Stroke width is 16 px. The miter limit is set to 4, which 
means 4 times of stroke width. When d > 64 px, the 
miter setting becomes bevel. 

d=52.5px d=81.6px

Cap
Three cap types are butt, round, and square.  Round 
and square extent 1/2 stroke width on each end. 

Order
The default order type puts fill on top of stroke. It will
cover half stroke width. Change the order if you want 
stroke on top of fill. 

stroke, fill, markers fill, stroke, markers

Dashes
Dashes are defined in the preferences.xml file, which 
is saved in InkscapePortable\Data\settings folder.

You can add a dash style to dashes group.

This dash will have 5px dash length and 15px dash 
interval if the stroke width is 1px.  

    <dash id="dash-5-15"
                style="stroke-dasharray: 5, 15" />

The object or path with this dash style will have a style
attribute (stroke-dasharry) in the SVG file. 

    style="... stroke-dasharray:5, 15; ..."

Markers (Arrowheads)
Markers are defined in the markers.svg file, which is 
saved in \App\Inkscape\share\markers folder. Here is
an example of a marker in the SVG file.

It is easier to create an object, convert it to a marker
(Object > Objects to Maker menu), save the svg 
file, edit the marker, then save it to markes.svg.  

<marker style="overflow:visible;" id="Arrow2Lend" 
         refX="0.0" refY="0.0" orient="auto" 
         inkscape:stockid="Arrow2Lend">
      <path transform="scale(0.8) rotate(180) translate(9.0,0)" 
          style="fill-rule:evenodd;stroke:#000000;stroke-width:1.0pt;
          stroke-linejoin:miter;stroke-miterlimit:10;" 
          d="M 0.0,0.0 L 0.0,-2.5 L -11.0,0.0 L 0.0,2.5 L 0.0,0.0 z "/>
    </marker>

The refX and refY is the anchor point of the marker, 
which is also rotation center of the object.

0.0,0.0
0.0,-2.5

0.0,2.5
-11.0,0.0

When you set marker style of a path, Inkscape places 
a copy of the marker in the SVG defs section, and the 
path refers to the definition.  

Stroke Width

You can change the values on XML editor.
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Font and Text
The easy way to edit text objects in Inkscape is to 
select the text, and press Ctrl + Shift + T to open
the Text and Font dialog to make changes. 

The flowed text was in a draft SVG 1.2 specification.  
Other programs can not render it properly (e.g. IE 10). 

Fonts
The Font tab of the Text and Font dialog shows the 
font families that are in the document and installed
in the computer.  You can customize the fonts.

The font size is in the unit of point (pt).  A 10pt text 
on paper is the minimum considered readable.

Comment out a line (line # 26) in the file \Inkscape
Portable\App\Inkscape\etc\fonts\fonts.conf.

Add a line to the Inkscape\etc\fonts\conf.d\51-
local.conf file before </fontconfig>.

Create an Inkscape\fonts folder and copy font files
 (*.ttf and *.otf) to this folder.

<!-- <dir>WINDOWSFONTDIR</dir> -->

<dir>./fonts</dir>

Google Fonts service provides a library of libre licen-
sed fonts.  Popular fonts include Open Sans, Roboto, 
Assistant etc.

Regular Text

Regular text does not have automatic line wrapping, 
and you need to press Enter key to insert a line break. 

Double click a text object to start selecting text.  
You can also choose the Text tool, and click a 
text object to select.

You can drag the I mouse cursor, or use Shift +
arrow keys, or Ctrl+A to select texts.
Press Ctrl+I to apply italic sytle.

Ctrl+ B to apply bold style.

You can use Alt+arrow keys to move each character 
or adjust spacing between charcters (kerning).

Shortcuts Alt + [ and Alt + ] rotate characters.

Flowed Text

You click and drag the Text tool to start flowed text.  
It automatically wraps the text to fill the width.  

<flowRoot id="flowRoot17"
   xml:space="preserve"
   style="font-style:normal;..."
   transform="matrix
   (0.264,0,0,0.264,0,81.1)">
   <flowRegion id="flowRegion19">
      <rect id="rect21"
          width="85.86" height="69.19"
          x="24.24" y="67.98" />
   </flowRegion>
   <flowPara id="flowPara23">
      This is an example of flowed text
   </flowPara>
</flowRoot>

This is an 
example of 
flowed text

You can convert it to regular text via menu Text > 
Convert to Text, however the converted text is 
wrapped inside two <tspan> elements.  It is likely
a bug of Inkscape. 

Change text fill color to change color.

It is recommended to have flowed text in Inkscape 
file, and save a copy of PDF file to be transmitted.  
If you have to transmit the SVG file, convert text to 
paths via menu Path > Object to Path. 

Text on a Path

A single line text object in Inkscape can link to a path 
and use it as a guide to bend the text's baseline. 

Evergreen Mills Road

Select both text and path, and choose menu Text > 
Put on Path. 

<text id="text1829"
   style="font-style:normal;..."
   xml:space="preserve">
   <textPath id="textPath1833"
      xlink:href="#path1831" >
      <tspan id="tspan1827"
         style="font-style:normal;..."
         dx="7.347435">Evergreen Mills Road</tspan>
   </textPath></text>

<path id="path1831"
   inkscape:connector-curvature="0"
   d="m 196.7,143.8 c 6.0,-4.6 ..."
       style="fill:none;stroke:#000000;stroke-width:..."/>

You can set the Fill and Stroke of the path to none or 
opacity to 0 to hide the path. 

ABCDEFGHabcdefgh12345
ABCDEFGHabcdefgh12345
ABCDEFGHabcdefgh12345
ABCDEFGHabcdefgh12345

ABCDEFGHabcdefgh12345 Arial Narrow

Open Sans

Roboto

Assistant

Times New Roman

Font Examples Names
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Select and Edit
Like in other software packages, objects must be 
selected before manipulation.  The first tool on 
toolbar is Select and Transform (S, F1, Spacebar).

Select with Keyboard Shortcuts

Sometimes it is convenient to use keyboard shortcuts 
to select objects.

Tab: Select next object in z-order.

Mouse Selection
You combine left mouse click with keyboard keys to 
make selections. 

Shift: Add an object to a selection.  If it is already

Alt: Select object underneath current selected one.

Ctrl: Select an object in a group.

selected, remove from selection.

Alt + Drag: Select objects that touch mouse path.

Drag: Select objects within the rectangle. 

Shift + Drag: Same as drag, but do not select the 

Click an empty space or press Esc key to deselect.

object when start dragging.

Locked or hidden objects are not selected.  Sometimes
you do not want to select an object, you can put it on 
a separate layer and lock the layer. 

Shift + Tab: Select previous object in z-order.

Ctrl + A: Select all objects on current layer.

Ctrl + Shift + A: Select all objects on all layers.

!: Invert selection on current layer.

Basic Editing

Here is a list of some very basic editing shortcuts. 
You need to get familiar with these operations.

Ctrl + D: Duplicate a copy of the object, it is easier

Z-Order: Pageup and Pagedown to change z-order. 

Group: Ctrl + G to group; Ctrl + Shift + G to ungroup.

When an object is selected, you can start basic editing 
like move (translate), scale, and rotate. 

Move: Drag an object to move.

Rotate: Click the selected object again to rotate.

Scale: Drag the corner arrow to scale an object.

Pressing the Ctrl key will restrict the move to horizontal 
or vertical, lock the scale aspect ratio, and constrain 
the rotation angle to a multiple of 15 degrees.

Paste Style: Ctrl + Shift + V to paste style.

to use than Ctrl + C and Ctrl + V. 

It is the "format painter" of Inkscape.

Transform

Transform Equations

Translate Rotate

Scale

When you move an object in a coordinate system, you 
can view it as moving the coordinate system, but the 
object stays at the same location. 

Old

New

Suppose you have a point in the new coordinate system
(x', y'), the point in the old coordinate system is (x, y).

You can write the point as [x' y' 1] and [x y 1], so you 
can use matrix calculations.

The equations for rotation and scale are, 

The transform matrix is,

You can also move, scale, or rotate objects in the 
Transform dialog box.  The Matrix tab is the place 
to enter transform matrix.

Transform Dialog

The values in the above dialog box rotate the object
30 degrees counterclockwise around lower left corner.

When scaling an object, sometimes you want stroke 
width and corner radius scale with the object.  You 
can set the options on the tool setting bar. 
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Color and Pattern

GIMP Palette
Name: Traffic Control Devices
# generated by goTrafficSign.com
 35  31  32  Sign Black
  0  86 150  Blue
121  69  00  Brown
241  94 124  Fluorescent Pink
193 215  46  Fluorescent Yellow ...
  0 111  81  Green
244 145  30  Orange
108  39  124 Purple
191  46  26  Red
255 255 255  White
255 210  79  Yellow
255 127  80  Coral (Reserved)
 90 147 193  Light Blue (Reserved)

Color Palette
The Color Palette bar and Swatches dialog box show  
color squares.  You drag and drop a color square to 
fill and stroke strips on status bar or a selected object.

You can create customized color palettes and save 

The palette files have same format as in GIMP.

them in Inkscape\share\palettes folder.

Gradient

Gradient is rarely used in engineering drawings, but 
you need to know the basics.  It is one of the most 
important features of vector graphics.

If you transform an object with gradient or pattern,

Select an object first, then choose the gradient tool.

toggle on two buttons on selector setting toolbar.

Inkscape objects can have different types of paint: 
none, flat color, gradient or pattern, and unset. 

Gra
dients

Patte
rn

s

Linear

Radial

<rect id="rect1285"
   style="fill:url(#linearGradient1293); ..."
   width="17.86" height="11.03"
   x="158.39" y="25.92" />

<linearGradient id="linearGradient1293"
   inkscape:collect="always"
   xlink:href="#linearGradient1291"
   x1="158.26" y1="31.44"
   x2="176.38" y2="31.44"
   gradientUnits="userSpaceOnUse" />

<linearGradient id="linearGradient1291"
   inkscape:collect="always" >
   <stop id="stop1287" offset="0"
      style="stop-color:#006f51;stop-opacity:1" />
   <stop id="stop1289" offset="1"
      style="stop-color:#ffffff;stop-opacity:1"  />
</linearGradient>

Gradient in SVG has two levels of elements.

Pattern in Inkscape is somewhat difficult to control. 
It is easy to create the pattern by drawing a grid of 
the pattern, make duplicates, and align them.  

Fill a new object with the pattern.

Apply menu Object>Pattern>Object to Pattern (Alt+I).

Pattern

Create a diamond shape and fill yellow.

Here are the steps to create a pattern fill,

Pattern Fill Align Duplicates

A clone is a linked copy of an object that updates itself
when the original changes.  The Create Tiled Clones 
dialog is a very powerful tool. 

Clone

<rect id="rect1304"
    transform="rotate(45)"
    x="160.31" y="-122.01"
    height="3.45" width="3.45"
    style="fill:#ffd24f;..." />

<use id="use1310"
   x="0" y="0"
   xlink:href="#rect1304"
   transform="translate(9.36,5.40)"
   width="100%" height="100%" />

Original

Clone

Sometimes you want to edit a clone independent of the
original. You can unlink the clone (menu Edit > Clone >
Unlink Clone, Shift+Alt+D).  The clone becomes a full 
copy of the original. 

Unlink Clone

When you import a PDF file with embedded fonts into 
Inkscape, the text becomes a group of glyph symbols.  
You need to ungroup them, then unlink glyphs from 
symbols to get paths of embedded font glyphs.  

Clipping and Masking

When engineers work on CAD drawings, we often start 
the drawing on one sheet, then use reference and 
clipping tools to separate it into multiple plan sheets.

The clipping tool in Inkscape has similar function, you 
can show part of drawing inside a path or an object.

Masking tool is similar to clipping, however color black 
makes masked area transparent (invisible) and white 
makes the area opaque (visible).

Enlarge A Map Area 5 Times
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Align and Layer

Align and Distribute
The align and distribute (Ctrl + Shift + A) dialog is a 
very powerful tool.  The tool is better designed than 
other graphic drawing software. 

Choose Page in the "Relative to" drop down list box;

Draw auxiliary lines to help align objects.

align objects to center of a page.

Align, snapping, layer, and guide are important tools 
in Inkscape. 

Snapping may not be important for artistic drawings,
but it is essential for engineering drawings.  You can
not do serious engineering drawings without the tool.

Guide and grid toggle is | and #.

The global snap toggle is % (Shift + 5).

Snapping

Snapping happens when you drag something.

Layers tool in Inkscape is good and simple.  Layers can
be easily hidden, locked, or reordered.  You can drawing 
everything on one layer if the drawing is very simple. 

Layer

You can create a sign
drawing using auxiliary 
lines and alignment tool.

The dimensions, spaces,
and letter paths are from 
FHWA Standard Highway
Signs and Markings Book.

Snap Centers of Objects

Snap an Item's Rotation Center

Toggle on Rotation Center button when move it. 

Shift + Click rotation center to move it back.

Both layer and group are element g in XML.

Objects on a hidden layer are not visible nor select-

If you want to trace objects on a bitmap, put the 
image on a layer and lock it. 

able.  You can hide a layer with all auxiliary lines.

You can change the current layer on status bar or 
layers dialog (Ctrl + Shift + L).

Inkscape guides are infinitely long straight lines.  They
are saved in the SVG documents.

Guides

Choose menu Object > Objects to Guides (Shift + G)

Double click a guide to set properties or delete it.

Turn on the ruler (Ctrl + R), and drag from ruler to 
create guides.

 to convert objects to guides.

The steps to draw a perpendicular line from a point:

Select the line; Ctrl + D, Shift + G create a guide.

Double click the guide; enter "+90" to Angle 
textbox, press key Enter.

Press B; draw a line from center of the dot to 
the intersection.

1.

2.

3.

In CAD programs, you can breakup a shape into lines 
and curves.  In Inkscape it takes a few steps to do so.

Breakup Object

Draw a rect with 0.1in radius

Select; Path > Object to Path

1.

2.

F2, select nodes3.
Break path at selected nodes

Re-select the path4.
Path > Breakapart

Draw 4 separate paths

Select; Path > Combine

1.

2.

F2, select nodes3.
Join selected nodes

Combine Paths

Breakup Object
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Extensions
Python Script File

Here is the skeleton code of a Python extension script.

Inkscape has a programming interface to expand its 
functionality.  An extension consists of an INX file 
and a python script file.  Most extensions are saved 
in this directory \inkscape\share\extensions. 

Extension Execution Steps

Those are the steps how a python script is executed 
as an Inkscape extension.

Inkscape reads INX file and collects arguments 
on the extension dialog, then calls the python
script with arguments.  

Python reads the temporary SVG and arguments.

The script modifies the temporary SVG file.

<?xml version="1.0" encoding="UTF-8"?>
<inkscape-extension xmlns="http://www.inkscape.org/...">
    <_name>Draw Tangent</_name>
    <id>com.gotrafficsign.drawtangent</id>
    <dependency type="executable" location="extensions">
                                              draw_tangent.py</dependency>
    <param name="point_to_circle"    type="boolean" 
                                     _gui-text="Point To Circle"></param>
    <effect>
        <object-type>all</object-type>
        <effects-menu> 
           <submenu _name="Render"/>
        </effects-menu>
    </effect>
    <script>
        <command reldir="extensions" interpreter="python">
                                                draw_tangent.py</command>
    </script>
</inkscape-extension>

Inkscape reloads the modified SVG file.

Inkscape passes additional arguments to the extension 
such as ids of selected elements.

(interpreter) your_script (--param=value)* /path/SVGfile | inkscape

Description (INX) File

The INX file describes which parameters the extension 
needs.  Inkscape will prompt a dialog for the user to fill. 
The arguments will be passed to the python file.  

Snap smooth nodes

Snap centers of objects

import sys
from math import *
import inkex
import simplestyle

class Draw_Tangent(inkex.Effect):
    def __init__(self):
        inkex.Effect.__init__(self)
        self.OptionParser.add_option("--point_to_circle",
                        action="store", type="inkbool", 
                        dest="point_to_circle", default=False)
        ......
    def effect(self):
        so = self.options #shorthand
        ......  
if __name__ == '__main__':   
    e = Draw_Tangent()
    e.affect()

Most interfacing code between Inkscape and Python
has already been written by others.

The inkex.py file uses optparse and lxml modules, 
and defines Effect class.

The optparse module parses arguments.

The lxml is for processing XML files.

Derive a class from inkex.Effect and write code in 
the effect(self) method.

Draw Tangent Extension

You can create an extension to draw tangent lines from
a point to a circle or between two circles. 

Auxiliary path

Extension Debug

The inkex module has a debug function which displays 
object or variable values.  The result of below code is 
Python 2.7.13 for Inkscape 0.92.2.

debug = True
if debug:
    cur_version=sys.version_info
    message = 'Python version: ' + str(cur_version) +'\n'
    inkex.debug(message)

The file extensionerrors.log records error messages. It 
is saved in this folder \InkscapePortable\Data\settings.

Python Code

The code below creates a line path and add it to the 
parent node (a layer or a group).  SubElement method 
constructs a node and adds it to its parent.

def draw_SVG_line( (x1, y1), (x2, y2), name, parent):
    line_style   = { 'stroke':'#000000', 'stroke-width':
                     str(Draw_Tangent.unittouu(e, '1px')), 'fill':'none' }
    line_attribs = {'style':simplestyle.formatStyle(line_style),
                    inkex.addNS('label','inkscape'):name,
                    'd':'M '+str(x1)+','+str(y1)+' L '+str(x2)+','+str(y2)}
    inkex.etree.SubElement(parent, inkex.addNS('path','svg'), 
                                                                              line_attribs )

The code below loops through selected nodes and
saves points from selected path.

for id, node in self.selected.iteritems():
    if node.tag == inkex.addNS('path','svg'):
        pts = get_n_points_from_path( node, 3 ) 

References

Python Book: 
Automate The Boring Stuff With Python

Online Tutorial:
http://www.hoboes.com/Mimsy/hacks/write-inkscape-.../
http://lxml.de/tutorial.html

Inkscape Wiki (8 articles):
http://wiki.inkscape.org/wiki/index.php/Script_extensions

Tangent Line Equations:
http://ambrsoft.com/TrigoCalc/Circles2/Circles2Tangent_.htm
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Other Topics

Image Markup
We often markup an image to convey ideas. It is easy 
to import an image into Inkscape, add markups, and
save it as an PDF file.  

You can use Snipping tool (or others) to capture and
copy a region of the screen and paste it in Inkscape.

Keep the image ratio and resize it.  Add texts and 
other objects and paths.

We discuss some practical Inkscape tips on this 
last tutorial page. 

You can import or export files in various formats in 
Inkscape. 

Import/Export

Text consists of groups containing cloned glyphs.

Choose "Poppler/Cairo import" for PDF files. It will 
preserve text paths. 

Save the SVG and PDF files.

Study Intersection

Creighton Rd (774) and Minerva Dr (2563) Intersection

TE Engineering 12/19/2017

Tracing
It is easier to create a drawing by tracing an image than 
drawing it from scratch.  The Bezier tool is essential
when you are tracing an image.   

Import an image onto a background layer.  Adjust 
layer opacity and lock the layer.

Create a tracing layer on top of background layer.  
Tracing the object with Bezier tool. 

Turn off or delete the background layer when you
save the final PDF file.

Inkscape has an auto-tracing tool, but it is not as good 
as manual tracing. 
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Background Map Traced From Aerial Photo

You can ungroup and unlink the glyphs.

When exporting page, drawing, or selection to PNG 
files, it doesn't have a white background.  Change 
Background color RGBA to #ffffffff on Document 
Properties dialog to get white background.

I would recommend Portable Inkscape version 0.92.2
in Windows.  Google search "Portable Inkscape" and 
go to portableapps.com to download it.

Inkscape Version

The advantage of this version is that all the customized
settings can be easily moved to a new computer. 

Inkscape can be executed as a command in a CMD
console window.  

Command Line

If you have hundreds of files that you want to convert
file format, you can write a Python script and call the
Inkscape as a command.  Here are a few examples,

The preferences.xml file is saved in this folder, 

InkscapePortable\Data\settings\

The extensions are saved here, 
InkscapePortable\App\Inkscape\share\extensions

inkscape --export-pdf=filename.pdf filename.svg

inkscape --export-png=f1.png --export-dpi=600 f1.svg

inkscape --export-png=f1.png --export-width=400 f1.svg

inkscape --export-png=f1.png --export-background=#000000 
                 --export-background-opacity=1.0 f1.svg

inkscape --help

LaTeX Equations

The Inkscape 0.92.2 does not come with a LaTeX 
extension.  You can download WriteTeX extension 
and insert equations into SVG file.  

Add LaTeX and pdf2svg directories to system path.  

\[ \begin{bmatrix} x_o & y_o & 1\\ \end{bmatrix}  = 
 \begin{bmatrix} x & y & 1 \\ \end{bmatrix}  
\cdot T_{\ast}   \]

Drawing Library

If engineers put common drawing blocks on an SVG file
and share it among fellow engineers, Inkscape will gain
popularity faster.  

WriteTeX calls pdf2svg to convert LaTeX result PDF 
to SVG file.  You need a copy of pdf2svg (github).  

Enter equations in "LaTeX Source" textbox,
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